We realize that not every PHP script will work correctly the first time it is run. This may be, in large part, due to the configuration of the server. Listed below are known compatibility issues with HostVise that can easily be fixed.

 

Issue #1: Deprecated ereg_replace()

Screenshot: Click Here
Error: Deprecated: Function ereg_replace() is deprectated in : eval()’d code on line 1 Deprecated: Function ereg_replace() is deprecated
Fix: Turn PHP Warnings Off (make sure you are turning WARNINGS off and NOT ERRORS) in php.ini

 

Issue #2: SQL Syntax error when updating

Screenshot: Click Here
Error: You have an error in your SQL syntax, check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1.
Fix: Turn “magic_quotes_gpc” On in php.ini. One way to do this is (if you have the permissions) is to create a .htaccess file in the hostvise directory and add this line of code to the file: “php_flag magic_quotes_gpc On”.